Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weird error message in 13.1

    Hi-this is probably a question best for Stata support, but my students are going bonkers so I am hoping someone here knows what is going on.

    The university where I teach renews their Stata license every year and just renewed their license a few days ago. Everything was fine before the renewal. However, now on some Macs (not Windows machine), users are getting strange errors such as the following (see image also) when trying to run a regresion:

    f_coef_table() in lmatabase, compiled by Stata 13.1, is too new to be run by this version of Stata and so was ignored
    <istmt>: 3499 _coef_table() not found

    An error of a similar nature appears when trying to import an Excel spreadsheet.

    Anyone have any ideas? The students have tried uninstalling/reinstalling with no success.

    Thanks for any insights.

    m
    Click image for larger version

Name:	stata_error.png
Views:	1
Size:	252.5 KB
ID:	41523

  • #2
    A similar problem (with explanation and solution) was posted here:

    http://www.stata.com/statalist/archi.../msg00205.html
    You should:

    1. Read the FAQ carefully.

    2. "Say exactly what you typed and exactly what Stata typed (or did) in response. N.B. exactly!"

    3. Describe your dataset. Use list to list data when you are doing so. Use input to type in your own dataset fragment that others can experiment with.

    4. Use the advanced editing options to appropriately format quotes, data, code and Stata output. The advanced options can be toggled on/off using the A button in the top right corner of the text editor.

    Comment


    • #3
      Originally posted by Roberto Ferrer View Post
      A similar problem (with explanation and solution) was posted here:

      http://www.stata.com/statalist/archi.../msg00205.html
      Thanks! Hopefully that is it and an "update all" will cure everyone.

      Comment


      • #4
        The problem can be clearly resolved after you report version of Stata you are working with. Stata 13.1 is only partial version. There are many different Stata's marked 13.1. So you need to report the full version 13.1.x.y.
        StataCorp does not require you to determine the version completely, they simply state the date, which must be reported by about to be considered up-to-date:
        "Type about in Stata and note the "Revision" date. If you see a date earlier than "26 Jun 2014", you need to update Stata."
        I'd say both are important.

        The update may or may not resolve the issue. See for example the following post.

        PS: you have a very original way of making screenshots How about Alt+PrtScr?

        Best, Sergiy Radyakin

        Comment


        • #5
          Hi all,

          I am having the same problem but update all is not helping. I have a revision date of 06 May 2014 but am not sure what to do other than the update. Any guidance? Thanks!

          Comment


          • #6
            Uninstall and re-install is a generic strategy for troublesome programs. -update all, force- can also be tried.

            The current update level is June 26, 2014.
            -------------------------------------------
            Richard Williams, Notre Dame Dept of Sociology
            Stata Version: 16.0MP (2 processor)

            EMAIL: rwilliam@ND.Edu
            WWW: https://www3.nd.edu/~rwilliam

            Comment


            • #7
              Heather, if for any reason you don't want to (or can't) disturb/destroy/change your Stata installation, you can simply validate it with the Stata Installation Qualification tool. It will simply confirm to you that your installation is what the StataCorp developers meant to be. Otherwise it will tell you where the problem is. Best, Sergiy Radyakin.

              Comment


              • #8
                Thanks everyone. It looks like the problem is coming from the updates. I get an error now that says "StataMP can not be moved to StataMP_old" so now I'm just trying to fix that problem...

                Comment

                Working...
                X